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Troubleshooting PsiWin 2.3
Synchronization Problems
This document discusses various problems that may be encountered when synchronizing Psion Agenda
and Data files or the Contacts program (Series 5mx and netBook only) with Microsoft Outlook 97/98,
Microsoft Schedule+ 7.0/7.0a/7.5 or Lotus Organizer 2.1/97/97GS. Some familiarity with these
applications, Windows 95/98/NT 4.0 and your Psion is assumed. You will also need a full installation
of your PC PIM.

This document should be used in conjunction with the appropriate guide to setting up a synchronization.

Setting up your synchronization correctly
The majority of synchronization problems are caused by an incorrect synchronization set up. Please
make sure you have read the appropriate Synchronizing your Psion with… support document first.
These explain the correct way to set up a synchronization.

General things to try if you experience synchronization problems
By far the most common cause of a synchronization failing, apart from the wrong files being chosen in
the set up, is corruption or spurious entries in one of the files. To test whether this is the case,
synchronize a new Psion Agenda and/or Data file with a new Outlook profile, Schedule+ file or
Organizer file. If this synchronization works then the problem is with one of the original files. A process
of elimination, by synchronizing one file at a time with blank files, should highlight which file is at fault.
If the synchronization with new files does not work, look through the list of common problems later in
this document to see if the particular problem is listed. If not, it is likely that either PsiWin or your PC
PIM is not installed properly (for example, with Outlook 98 you will need a full installation for
synchronization to work). See the Uninstalling and Installing PsiWin 2.x support document or contact
the supplier or manufacturer of your PC PIM.

1. The first thing to try is to delete your Machine details. When PsiWin 2.3 connects to a machine for
the first time it asks you to enter a name for that machine. This will register details about your Psion
on your PC. Sometimes this information can become corrupt.

To delete this information, click the Start button and
select Programs, then PsiWin 2.3, and then Machine
Manager. This will present you with a list of current
registered machines. Highlight your machine and click
Delete This Owner, or just click the Remove details
of selected machine button. The next time you
connect your Psion you will be asked to give it a
name. At this point you should type in something
different from the machine name you have just
deleted.

After doing this you should make a new backup and recreate any synchronizations.
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2. If this doesn’t solve the problem, you should try a Tidy/extract (Series 3 range) or a Tidy/archive
(Series 5 range and netBook) operation on your Agenda file or a Merging in operation on your Data
file.

To perform a Tidy/extract operation on your
Series 3 range Agenda, open the file and press
Psion + T. Change the Tidy/extract line to
Copy to file, enter a file name (in this example,
Test) and the disk to create this file on. Then,
select Whole Agenda on the Range line, and
All entries on the Status filter line.

Then press Enter. This will extract all the information from your Agenda into a new file (in this
example, Test). Note that this is not the same as copying the file.

To perform a Tidy/archive operation on your
Series 5 range or netBook Agenda, open the
file, and select More, then Tidy/archive from
the File menu. Change the Tidied entries are
line to Copied to new file. Select All entries
on the  Which entries line and change the
Range line to Whole agenda.

Enter a file name (in this example, Test) and select a folder and disk to create the file in. Then tap
the OK button or press Enter. This will extract all the information from your Agenda into a new
file (in this example, Test). Note that this is not the same as copying the file.

To perform a Merge in operation on your Series 3
range Data file, open the file and press Psion + N.
Enter a name for the new file (in this example, Test)
and press Enter. This will automatically launch the
new file.

In this new file, press Psion + M. In the Merge in
dialog change the Disk line to the disk on which your
original Data file is kept, and select the filename on the
From: Name line. Change the Merge in line to Data.
Then press Enter.

To perform a Merge in operation on your Series 5
range or netBook Data file, open the file and press Ctrl
+ N. Enter a name for the new file (in this example,
Test), select the folder to create it in and press Enter.
This will automatically launch the new file.

In this new file, press Shift + Ctrl + I. In the Merge in
dialog, change the Disk and Folder lines to the disk
and folder on which your original Data file is kept, and
select the filename on the Name line. Then press
Enter.

3. Once these steps have been performed, set up a new synchronization or synchronizations to use the
newly created files.

4. If you still have no success, the next step is to export your PC PIM’s file or folders as text and re-
import them into a new file or new folders. See the relevant section below for information on how to
do this with Microsoft Outlook, Schedule+ 7.x and Lotus Organizer.
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Outlook
i. Create a new folder to receive the

information that you are about to export.
To do this:
In Outlook, select New, then Folder from
the File menu. Type in a name for this
folder (in this example, Test), select
which type of information this folder is
going to contain (this should be the same
as the folder you are exporting, in this
example, Appointment Items) and select
the top level folder in the list of folders (in
this example, Personal Folders). Then
click the OK button.
The new folder will appear in the folder
view in Outlook (if you have this
showing).

ii. Next, select Import and Export from the
File menu.

iii. Select Export to a file and click the Next
button.

iv. Select the folder you wish to export (in this case Calendar). And click the Next button.

v. Select Comma Separated Values
(Windows) and click the Next button.

vi. Type in a name for the export file (in this
example, Calendar.txt) and click the
Next button. Then click the Finish button.

vii. To import the file into a new folder, again
select Import and Export from the File
menu.

viii. Select Import from Schedule+ or another program or file and click the Next button.

ix. Select Comma Separated Values
(Windows) and click the Next button.

x. Type in the name you gave the export file
(in this example, Calendar.txt) and click
the Next button.

xi. Select the folder that you created earlier (in this example, Test)
and click the Next button. Then click the Finish button.

xii. Set up a synchronization to use the new folder.

It may also be necessary to set up a new Outlook profile and
import the data into this. See the relevant section later in this
document for information about creating a new Outlook profile.
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Schedule+ 7.x
i. Create a new Schedule+ file. To do this:

Select New from the File menu. Then type in a name for the new file, for
example, Test, then click the Save button.

ii. To export your data to a text file, open the original Schedule+ file, and
select Export, then Text from the File menu.

iii. Select the type of items you wish to export (in this example,
Appointments) and click the Next button.

iv. Select the date range you wish to export and click the Next
button.

v. In the next two dialogs accept the defaults by clicking the Next
button twice.

vi. Click the Add All button to export all the
fields and then click the Next button.

vii. Type in a name for the export file, or
accept the default, and click the Finish
button.

viii.To import, first open the new Schedule
file you created earlier by selecting Open,
then Archive or Project Schedule from
the File menu.

ix. In this file, select Import, then Text from the File menu.

x. Type in the path and name of the export file. If you accepted the default when exporting, this
will already be entered. Then click the Next button.

xi. Accept the defaults in the next two dialogs
by clicking the Next button twice.

xii. Select the type of data in the export file (in
this example, Appointments) and then
click the Next button.

xiii.On the final screen, you need to map the
fields between the two Schedule+ files.
Opposite each field, to its right it will say
IGNORE THIS FIELD. Click on this and
a down arrow  will appear. Click on this
and a list of field types will appear. Select
the type that corresponds to the field on the
left. Do this for all the fields and click the
Finish button.

xiv.Set up a new synchronization to use the new Schedule file.
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Organizer
i. Create a new section to receive the

information that you are about to export.
To do this:
In Organizer, select Customize from the
Section menu.

ii. Click the Add button.

iii. On the Section type line, select the type of section you
would like to add (in this example, Calendar) and type in
the name you wish to use for this section (in this example,
Test). Then click the OK button.
The new section will appear as a tab in the main view in
Organizer.

iv. To export a section, select Export from
the File menu. On the From section line,
select the section that you wish to export
(in this example, Calendar), select ASCII
Delimited Text on the Files of type line
and type in a file name (in this example,
Calendar.txt). Then click theExport
button.

v. To import the information, select Import
from the File menu. On the Into section
line, select the section you created earlier,
select ASCII Delimited Text on the Files
of type line, and select the file you
exported to earlier (in this example,
Calendar.txt). Then click the Import
button.

vi. Set up a new synchronization to use the
new section.

It may also be necessary to import the
data into a new Organizer file.
To create a new Organizer file, select New from the File menu, type in a name for the file and
then click the OK button.
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5. Check your PC PIM for spurious entries. These include:

• Repeating entries with only one occurrence.

• Alarmed entries with a reminder set for before 1980.

• Entries with a carriage return at the end of the subject line.

• In Outlook, entries with a ‘crossed swords’ symbol. Double-click on the symbol to resolve the
problem.

Creating a new Outlook Profile
This should only be attempted if you have a non-networked copy of Outlook. If you use Outlook on a
network that is running Exchange, you should contact your Network Administrator.

To create a new Outlook profile:

i. Click the Start button, select Settings, then Control Panel. Double-click the Mail and Fax
icon (Mail icon if you have Outlook 98).

ii. In the Properties dialog, click the Show profiles button. This will show a list of all the Outlook
profiles on the PC. Then click the Add button.

iii. Select Manually configure information services
and click the Next button.

iv. Type in a profile name (in this example, Test)
and click the Next button.

v. In the Properties dialog click the Add button to add an information service to the new profile.

vi. Highlight Personal Folders and click the OK button.

vii. Type in a name for the Outlook file (in this example, Test.pst) and
click the Open button.

viii.Select No encryption and click the OK button.

ix. Click the OK button again and then the Finish button. Click the Close button to exit the Wizard.

x. Open Outlook, and select Options from the
Tools menu. On the General page, select
Prompt for a profile to be used and click the
OK button.

The next time you start Outlook you will be asked which profile you wish to use.
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Other problems
This section describes solutions to other problems that can occur with a synchronization.

Microsoft Outlook: Failed to open Outlook
This error message can appear just after the start of the synchronization
process. There can be two reasons for this message appearing.
The first is that your Outlook profile has been incorrectly entered.
To check this, first make sure you have your profile name.

You can find this in Outlook by selecting Options from the Tools menu. On the General page, if
Always use this profile is selected your profile name will be in the text box next to it. If Prompt for a
profile to be used is selected, your profile name is the one you select when you start up Outlook.
Follow the Synchronizing your Psion with Microsoft Outlook support document to ensure that this
information has been entered correctly in the synchronization properties.

The second reason is that the path to the Outlook folder(s) you are
synchronizing has been incorrectly specified. To check the path to the
folder, make sure you can see the Folder view in Outlook. To show it,
select Folder view from the View menu.
In the example shown here, if you were trying to synchronize the
Example folder, the path would be:

Program Files\Contacts\Example
If you have a top level folder that looks like

Mailbox – [Chris Dickins] or

Outlook Today – [Chris Dickins]
then the path would be:

Chris Dickins\Contacts\Example

Follow the Synchronizing your Psion with Microsoft Outlook support
document to ensure that this information has been entered correctly in the
synchronization properties.

Microsoft Outlook: Failed to open Custom form, Outlook will open an Outlook form
instead
This error message is due to conflicting entries. Find the Outlook entries that have a ‘crossed swords’
symbol. Double-click this symbol to resolve the conflict and the problem should be solved.
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Lotus Organizer 2.1: Synchronizer cannot access required directory
This is due to the incorrect version of a particular file being loaded (the Organizer API).

To find this file, click the Start button, select
Find, then Files or folders. On the Named: line,
type orgapi.dll and make sure that the Look in:
line is set to your C drive (or whichever drive the
Organizer files were installed to). Then click the
Find now button. You should get a list of two
copies of the file. Right-click on each in turn and
select Properties. One of the files should have a
Modified date of 7th November 1995. Right-click
again on the file with this date and select Delete.
Then confirm the deletion and restart the PC. All
should now be well.

Lotus Organizer: Cannot find xxxxxxx (section name)
This error message is due to the section name being incorrectly entered in the
synchronization properties. Open Organizer and check the name of the relevant
section. Then enter the section name in the synchronization properties (the
Synchronizing your Psion with Lotus Organizer support document shows you
how to do this).

Lotus Organizer: Unable to open xxxxxxx (section name)
This is due to a problem in Organizer where, if you rename a section, Organizer
will sometimes not recognise the change. The solution here is to rename the
section back to its original name and change the synchronization properties to
reflect this.

To do this, right-click on the relevant section’s tab.
Select Rename, type the original name on the New
name line, then click the OK button. Follow the
Synchronizing your Psion with Lotus Organizer
support document and enter this information in the
synchronization properties


